owncloud no encuentra servidor
#21
gracias don peter
voy avolver a ins talar desde cero todo y si
no funciona hare lo que dices
saludos
 Responder
#22
buenas
necesito una ultima ayuda y si ni lo soluciono lo dejo
he reinstalado desde cero el servidor owncloud dando permisos a la carpeta 777
pero ahora me dice que debo actualizar a libxml2 2.7.0
no se nada de linux y por lo tanto cualquier ayuda sera bienvenida.
gracias
 Responder
#23
(25-01-2017, 06:49 PM)gonac58 escribió: buenas
necesito una ultima ayuda y si ni lo soluciono lo dejo
he reinstalado desde cero el servidor owncloud dando permisos a la carpeta 777
pero ahora me dice que debo actualizar a libxml2 2.7.0
no se nada de linux y por lo tanto cualquier ayuda sera bienvenida.
gracias

Que currada te estás metiendo compañero!. Por lo que veo no instalas el owncloud directamente desde el appcenter de tu QNAP no?. Desde ahí podrías haber desinstalado e instalado de nuevo.

Por otro lado, investigando he encontrado de nuestros amigos qnapclub.com lo siguiente:

Step 1:
Replace libxml2:
log in to your nas via ssh, issue the following codes after another:
CODE: SELECT ALL
Código:
cd /usr/lib
mv libxml2.so.2.6.30 /share/CACHEDEV1_DATA/.qpkg/ 
cp /usr/local/medialibrary/lib/libxml2.so.2.9.2 .
ln -sf libxml2.so.2.9.2 libxml2.so
ln -sf libxml2.so.2.9.2. libxml2.so.2
/etc/init.d/Qthttpd.sh restart



Check if the libxml2 is correctly loaded by issuing the following command:
CODE: SELECT ALL
Código:
/usr/local/apache/bin/php -i | grep libXML


If everything is ok, it should look like this:
Cita:libXML support => active
libXML Compiled Version => 2.6.30
libXML Loaded Version => 20902
libXML streams => enabled


Step 2:
Patch the util.php from owncloud:
You should already have downloaded and extracted owncloud 9.0.2 somewhere on your nas. You should also know the path to that.
CODE: SELECT ALL
Código:
chmod -R httpdusr:administrators /share/Web/owncloud

is perhaps also necessary.

There is a bug in the current owncloud (9.0.2) which does only check the libxml2 version used to compile the apache, not which version is loaded. 
CODE: SELECT ALL
Código:
sed -i 's/LIBXML_DOTTED_VERSION/LIBXML_LOADED_VERSION/g' /share/Web/owncloud/lib/private/util.php


Replace the "..." with the actual path to your ownloud. If you used the standard installation, this path SHOULD work.

Now open the owncloud website and do the upgrade/install (or put some values in the config.php or whatever it needs to get owncloud running)

Step 3:
Patch the checksum warnings:
This is not necessary, but it's just annoying when logging in as admin and owncloud complains about the wrong checksum on the util.php.
Since owncloud is using code signing to prevent malicious software to modify the core libraries, it's perfectly legit for the warning to appear.
Altering the signature file will also not help, since this file is also checksumed.
So the only way to get rid of the warning is to set the branch of owncloud to something other than stable. We will set it to "custom":
Cita:sed -i 's/stable/custom/g' /share/Web/owncloud/version.php

Replace the path to owncloud with your actual path as above.


El hilo en cuestión es este por si te apetece echarle una lectura: https://forum.qnap.com/viewtopic.php?f=32&t=110563

Saludos!
 Responder
#24
hola buenas
pues eso que me rindo.
entre lo poco que se de linux y lo dificil de la solucion, lo dejo.
vuelvo al dropbox esperando que una nueva version no deba yo actualizar una libreria concreta.
se supune que la actualizacion debe venir con la propia aplicacion.
gracias a todos por vuestra ayuda.
saludos
 Responder
#25
(27-01-2017, 04:47 PM)gonac58 escribió: hola buenas
pues eso que me rindo.
entre lo poco que se de linux y lo dificil de la solucion, lo dejo.
vuelvo al dropbox esperando que una nueva version no deba yo actualizar una libreria concreta.
se supune que la actualizacion debe venir con la propia aplicacion.
gracias a todos por vuestra ayuda.
saludos

No fastidies tío. No te rindas tan rápido. Ya lo echaste a andar una vez, así que ya sabes que eres capaz de hacerlo. Yo lo tengo montado sobre CentOS y es una maravilla, así que la versión que está incluida en el QNAP aunque no la conozco no debe diferir demasiado.
No te rindas que te aseguro una vez lo tengas funcionando verás el subidón que te va a dar.
 Responder
#26
bueno pues leyendo por internet he visto que el ultimo update de firm de qnap ha destrozado al owncloud y expertos en linux, al menos mucho mas que yo, siguen teniendo problemas con lib, apache..etc.
lo que me lleva a una decision, lo dejo y a esperar que qnap se ponga las pilas con esos bugs de los que ya tiene tikets para resolver.
saludos
 Responder
#27
(29-01-2017, 10:13 AM)gonac58 escribió: bueno pues leyendo por internet he visto que el ultimo update de firm de qnap ha destrozado al owncloud y expertos en linux, al menos mucho mas que yo, siguen teniendo problemas con lib, apache..etc.
lo que me lleva a una decision, lo dejo y a esperar que qnap se ponga las pilas con esos bugs de los que ya tiene tikets para resolver.
saludos

Hola,
¿Ya tienes Owncloud?
Tenía el mismo problema que tu y ya me funciona, quizá tengas el mismo problema que yo.
 Responder
#28
hola kilerfer
tuve que esperar a un nuevo firmware para, por fin, tener owncloud funcionando
des pues tuve problemas para actualizarlo pero gracias a ganekogorta lo solucione metiendo un comando en phpmyadmin
me ha costado pero lo tengo
gracias
saludos
 Responder


Usuarios navegando en este tema: 2 invitado(s)


Powered By MyBB 1.8.6, © 2002-2018 MyBB Group
Hora: 12-12-2018, 12:29 AM