Haciendo pruebas con una Web.
#1
Buenos dias. Aquí va mi consulta diaria. Big Grin
Estoy haciendo pruebas con el servidor Web. He instalado y configurado sin problema MyphpAdmin y Wordpress y funciona todo. Pero al rato me he dado cuenta de que la direccion de internet para verla desde fuera es siempre con el numero del puerto incluido https://minombredeqnap.myqnapcloud.com:8081/ y claro, pues queda bastante feo. ¿Hay alguna manera de deshacerse del numero de puerto en la barra de direcciones? si pongo en el navegador https://minombredeqnap.myqnapcloud.com/web/ directamente no me enseña la pagina.
QNAP TS-251-A
4 GB RAM
SLOT 1 DISCO SSD 500 Gb Samsung Evo.
SLOT 2 DISCO WD RED 3 TB
2 DISCOS DUROS EXTERNOS USB 3.0 DE 1 TB CADA UNO.
 Responder
#2
Supongo que el 80 estará reservado para el acceso al propio nas y el 443 para lo mismo pero por https.

Enviado desde alguna parte del Universo
 Responder
#3
Si quieres deshacerte de esta dirección, deberias plantearte un nombre de dominio. Desde el propio servidor Web puedes asociarlo. (Ten en cuenta que necesitaras DNS para asociarlas a la Ip de tu NAS).
Hay un compañero que publicó una mini Guia sobre este tema.
Red2pepper
---------------
TS-453mini 8Gb
 Responder
#4
El nombre de dominio para tener DNS por ahora no me hace falta porque es solo para probar si todo funciona bien. ¿o sea que lo que yo quiero no se puede no?
QNAP TS-251-A
4 GB RAM
SLOT 1 DISCO SSD 500 Gb Samsung Evo.
SLOT 2 DISCO WD RED 3 TB
2 DISCOS DUROS EXTERNOS USB 3.0 DE 1 TB CADA UNO.
 Responder
#5
Se puede, pero tienes que comprar un nombre de dominio Big Grin

Si lo quieres gratis, tienes que utilizar el de QNAP, que incluye el puerto. Si no, QNAP te tendria que dar un dominio por puerto y se llenaria de dominios y ademas te olvidarias de ellos, piensa que otros servicios en cloud como replicacion remota utilizan tudominio.myqnapcloud.com pero con diferente puerto. 

Saludos!
TS-251A-4G  2 x Seagate ST4000VN000 4TB
 Responder
#6
Ok gracias.
QNAP TS-251-A
4 GB RAM
SLOT 1 DISCO SSD 500 Gb Samsung Evo.
SLOT 2 DISCO WD RED 3 TB
2 DISCOS DUROS EXTERNOS USB 3.0 DE 1 TB CADA UNO.
 Responder
#7
Siempre puedes usar ddns, con noip, gratuito y compatible con la gran mayoría de routers y sobre todo con nuestros qnap

Enviado desde alguna parte del Universo
 Responder
#8
Ddns con noip no me funciona. Pongo los datos que tengo registrados allí y cuando aplico me sale una ventana de error interno dns. Tampoco sé que poner en la casilla Nombre De Equipo:

Bueno ya no hace falta. Acabo de comprar en 1&1 el dominio y estan de ofertas. 1,20 € el primer año sin compromiso de permanecer mas de 1 año.
QNAP TS-251-A
4 GB RAM
SLOT 1 DISCO SSD 500 Gb Samsung Evo.
SLOT 2 DISCO WD RED 3 TB
2 DISCOS DUROS EXTERNOS USB 3.0 DE 1 TB CADA UNO.
 Responder
#9
(16-03-2017, 12:17 PM)madelmanhouse escribió: Ddns con noip no me funciona. Pongo los datos que tengo registrados allí y cuando aplico me sale una ventana de error interno dns. Tampoco sé que poner en la casilla Nombre De Equipo:

Bueno ya no hace falta. Acabo de comprar en 1&1 el dominio y estan de ofertas. 1,20 € el primer año sin compromiso de permanecer mas de 1 año.

A ver, me ha saltado la duda porque antes de tener los dominios activos hice las mismas pruebas y no me pasaba lo que dices.

Por suerte tengo una web en test sin dominio y lo he podido comprobar, aunque en la definición de puertos te indique que para acceder a la web necesitas indicar el puerto, no es necesario. Eso sí asegurate de haber creado un host virtual y tener asignado el puerto 80 en el servidor Web.

nombre del host: red2pepper
nombre de carpeta: /Web/red2pepper

Indica un nombre (si extensiones .com ni nada) y vinculalo al directorio donde se encuentra. Despues accede al navegador con tu dirección myqnapcloud.

http://xxxxxxx.myqnapcloud.com/red2pepper/

Deberia funcionar si tienes asignado el puerto por defecto (80)
Red2pepper
---------------
TS-453mini 8Gb
 Responder
#10
Lo tengo como dices. Puertos abiertos y host virtuales creados.

Me pasa una cosa muy curiosa que no entiendo. Estoy intentando instalar un foro en una carpeta /foro como no lo consigo se me ha ocurrido subir a esa carpeta un index.html y veo el index.html correctamente pero el index.php que es el que tiene que leer no lo lee y por eso no muestra la pagina, digo yo...
QNAP TS-251-A
4 GB RAM
SLOT 1 DISCO SSD 500 Gb Samsung Evo.
SLOT 2 DISCO WD RED 3 TB
2 DISCOS DUROS EXTERNOS USB 3.0 DE 1 TB CADA UNO.
 Responder


Usuarios navegando en este tema: 1 invitado(s)


Powered By MyBB 1.8.6, © 2002-2018 MyBB Group
Hora: 12-12-2018, 07:56 AM