Problemas con comando PHP en terminal
#1
Hola a todos!

estos días quería instalar una pagina web con composer y para esto debía ejecutar el comando PHP ($ curl -sS https://getcomposer.org/installer | php $ php composer.phar install) en la terminal linux, pero al momento de ejecutarlo me indica que el comando PHP no lo encuentra, busque en google y decía que revisara la versión de PHP pero nada de esto resulta.

que tengo que hacer para que me reconozca este comando?, según qnap la versión instalada es PHP Version 5.5.38


el error es el siguiente:


[~] # curl -sS https://getcomposer.org/installer | php $ php composer.phar ins>
-sh: php: command not found
[~] # curl: (23) Failed writing body (0 != 16133)





Muchas Gracias!
Angel QNAP TS-110
  Shy  HS -210
 Responder
#2
(04-04-2017, 03:23 PM)Ronhead escribió: Hola a todos!

estos días quería instalar una pagina web con composer y para esto debía ejecutar el comando PHP ($ curl -sS https://getcomposer.org/installer | php $ php composer.phar install) en la terminal linux, pero al momento de ejecutarlo me indica que el comando PHP no lo encuentra, busque en google y decía que revisara la versión de PHP pero nada de esto resulta.

que tengo que hacer para que me reconozca este comando?, según qnap la versión instalada es PHP Version 5.5.38


el error es el siguiente:


[~] # curl -sS https://getcomposer.org/installer | php $ php composer.phar ins>
-sh: php: command not found
[~] # curl: (23) Failed writing body (0 != 16133)





Muchas Gracias!

Buenas,

Prueba con este comando a ver: 

curl -sS -k https://getcomposer.org/installer | /mnt/ext/opt/apache/bin/php -d detect_unicode=Off

A ver si tienes suerte (fuente: https://forum.qnap.com/viewtopic.php?t=84158)
Saludos!.
 Responder
#3
Gracias DonPeter

pude descargar el composer pero sigo teniendo problemas en la instalación, puesto que no reconoce el comando php

Downloading...

Composer (version 1.4.1) successfully installed to: /root/composer.phar
Use it: php composer.phar

y cuando ejecuto PHP me sigue apareciendo el mismo error.

[~] # php composer.phar
-sh: php: command not found


probé en realizar la instalación por medio de un archivo SH y me aparece el mismo mensaje de PHP

composer.sh: line 1: @php: command not found

Angel QNAP TS-110
  Shy  HS -210
 Responder


Usuarios navegando en este tema: 1 invitado(s)


Powered By MyBB 1.8.6, © 2002-2018 MyBB Group
Hora: 19-01-2018, 06:36 AM