Plexdrive
#31
Sale esto

[~] # ls -l /share/CACHEDEV1_DATA/.qpkg | grep rive
drwxr-xr-x 2 admin administrators 4096 2018-09-12 10:01 drive/
drwxr-xr-x 2 admin administrators 4096 2018-09-12 09:17 plexdrive/
drwxrwxr-x 2 admin administrators 4096 2018-09-10 20:17 PlexDrive/
[~] #
 Responder
#32
Tengo como admin, permisos de lectura, escritura y ejecucion en los 3 directorios.
 Responder
#33
(13-09-2018, 08:00 PM)enrey escribió: Sale esto

[~] # ls -l /share/CACHEDEV1_DATA/.qpkg | grep rive
drwxr-xr-x  2 admin    administrators 4096 2018-09-12 10:01 drive/
drwxr-xr-x  2 admin    administrators 4096 2018-09-12 09:17 plexdrive/
drwxrwxr-x  2 admin    administrators 4096 2018-09-10 20:17 PlexDrive/
[~] #

Vale, pero entonces no entiendo porque te dio error 

"Cuando pongo esta línea
chown admin:administrators /share/CACHEDEV1_DATA/.qpkg/drive
Me salta este error:
chown: /share/CACHEDEV1_DATA/.qpkg/drive: No such file or directory"

Según el ls (listar) anterior "ls -l /share/CACHEDEV1_DATA/.qpkg | grep rive" y su resultado "drwxr-xr-x  2 admin    administrators 4096 2018-09-12 10:01 drive/"

indica que existe "drive" en la ruta "/share/CACHEDEV1_DATA/.qpkg" y por ello no debería dar error al ejecutar "chown admin:administrators /share/CACHEDEV1_DATA/.qpkg/drive"

Mi recomendación en el caso de scripts es probar primero línea a línea a mano desde la consola.

Ya has visto que una falta de un caracter te puede tirar al traste el comando (mira lo del ls que te dije para repetir porque me deje un "/" delante de la ruta.

Las carpetas que tienes están organizadas como en el esquema siguiente
   
recuerda que tienes dos "drive". Una ubicada en ".qpkg" y otra dentro de "plexdrive" que a su vez está en ".qpkg". Lo digo para que no te lies.

Prueba de nuevo "chown admin:administrators /share/CACHEDEV1_DATA/.qpkg/drive" que debería dejarte. De todas formas si puedes instalate un gestor gráfico tipo WinSCP que te facilita estas cosas de creación, cambio de propiedades y una visión mas gráfica del árbol de carpetas.

Ya nos cuentas algo.
Un saludo

Agur eta ondo ibili

Mon (TS-469Pro y TVS-673)
 Responder
#34
Hola

Alguien a usado el método de bluebonnet del foro de qnap?


Cita:I figured it out. Plexdrive needs to continually run in terminal, and as soon as you close the terminal session it breaks it (per my previous post). The solution is to use Tmux, which allows an ongoing terminal session to run even if you close the window. Apparently this is standard on linux, but qnap doesn't have it by default. Here are the directions I found in another post, and they work for me so far: 
1) Manually install Entware: https://qnapclub.eu/en/qpkg/286
2) Manually install tmux: https://qnapclub.eu/en/qpkg/395 
3) SSH to QNAP from computer
4) tmux 
5) enter the commands to launch plexdrive, outlined above
6) close entire terminal session - command entered keeps running
7) login to QNAP again by SSH
8 ) tmux a (get back to monitoring process you began in tux previously)

https://forum.qnap.com/viewtopic.php?t=137773
 Responder
#35
Cuando me lanzo el error, fue antes de crear la carpeta en manual, de hecho, como no estaba y tengo muchas dudas, pregunte, lo creo manual?, y en cualquier caso lo he creado manual y aplique permisos, no es ahi donde estoy atascado, es mas adelante, el paso siguiente.
 Responder
#36
[~] # chmod 755 /share/Plexdrive/plexdrive/share/CACHEDEV1_DATA/.qpkg/drive
chmod: /share/Plexdrive/plexdrive/share/CACHEDEV1_DATA/.qpkg/drive: No such file or directory
[~] #
Ese directorio no lo tengo
y no se si tengo que crearlo o esta mal esa orden y debiera de ser asi
chmod 755 /share/Plexdrive/plexdrive
chmod 755 /share/CACHEDEV1_DATA/.qpkg/drive

S@lu2

Suponiendo que sea como yo digo, unos pasos mas adelante me salta el siguiente error,

/share/CACHEDEV1_DATA/.qpkg/plexdrive/drive mount -c
-sh: /share/CACHEDEV1_DATA/.qpkg/plexdrive/drive: Permission denied
[/share/CACHEDEV1_DATA/plexdrive] #
 Responder
#37
(15-09-2018, 09:03 AM)enrey escribió: [~] # chmod 755 /share/Plexdrive/plexdrive/share/CACHEDEV1_DATA/.qpkg/drive
chmod: /share/Plexdrive/plexdrive/share/CACHEDEV1_DATA/.qpkg/drive: No such file or directory
[~] #
Ese directorio no lo tengo
y no se si tengo que crearlo o esta mal esa orden y debiera de ser asi
chmod 755 /share/Plexdrive/plexdrive
chmod 755 /share/CACHEDEV1_DATA/.qpkg/drive

S@lu2

Suponiendo que sea como yo digo, unos pasos mas adelante me salta el siguiente error,

/share/CACHEDEV1_DATA/.qpkg/plexdrive/drive mount -c
-sh: /share/CACHEDEV1_DATA/.qpkg/plexdrive/drive: Permission denied
[/share/CACHEDEV1_DATA/plexdrive] #
Efectivamente, creo que debería dar esos permisos a las carpetas que ya tienes.

Luego a ver qué comando tienes para ver si se refiere a carpetas existentes

Creo que en Actio y que tratas de ejecutar hay mezcla de rutas, supongo que por error de copia pega


Un saludo
Agur eta ondo ibili
Un saludo

Agur eta ondo ibili

Mon (TS-469Pro y TVS-673)
 Responder
#38
Ahora estoy en este paso
Creamos un script en "/share/CACHEDEV1_DATA/.qpkg/plexdrive" que se va llamar plexdrive.sh el cual va contener el siguiente contenido:

Código:
#!/bin/sh
/share/CACHEDEV1_DATA/.qpkg/plexdrive/drive mount -c /share/CACHEDEV1_DATA/plexdrive/.plexdrive -o allow_other /share/CACHEDEV1_DATA/homes/admin/Plexcloud -v 3 --cache-file=/share/CACHEDEV1_DATA/plexdrive/cache.bolt

Lo que hago aqui es escribir en putty  /share/CACHEDEV1_DATA/.qpkg/plexdrive/plexdrive.sh y escribo al final el codigo, ¿lo estoy haciendo bien o esta mal?

En el siguiente paso
Ahora el siguiente paso añadirlo al Appcenter, para eso vamos a la siguiente ruta  "/etc/config/qpkg.conf" y añadimos al final del archivo lo siguiente:


Código:
[plexdrive]
Name = plexdrive
Class = null
Status = complete
Version = 0.1
Enable = TRUE
Date = 2017-10-01
Shell = /share/CACHEDEV1_DATA/.qpkg/plexdrive/plexdrive.sh
Install_Path = /share/CACHEDEV1_DATA/.qpkg/plexdrive
QPKG_File = plexdrive.qpkg
Author = abufa

escribo en putty    /etc/config/qpkg.conf  (previamente tuve que dar permisos), y pego al final el codigo, reinicio el qnap, pero no veo ninguna app plexdrive, ni ninguna unidad montada.

Por otra parte he confirmado que no esta enlazado plexcloud, tengo una película en google drive, y haciendo un ls a plexcloud debería salir la película y no sale nada, esto es lo que pongo en putty
ls /share/CACHEDEV1_DATA/homes/admin/Plexcloud/

S@lu2
 Responder
#39
(16-09-2018, 07:52 AM)enrey escribió: Ahora estoy en este paso
Creamos un script en "/share/CACHEDEV1_DATA/.qpkg/plexdrive" que se va llamar plexdrive.sh el cual va contener el siguiente contenido:

Código:
#!/bin/sh
/share/CACHEDEV1_DATA/.qpkg/plexdrive/drive mount -c /share/CACHEDEV1_DATA/plexdrive/.plexdrive -o allow_other /share/CACHEDEV1_DATA/homes/admin/Plexcloud -v 3 --cache-file=/share/CACHEDEV1_DATA/plexdrive/cache.bolt
Es decir que ya tienen que existir las dos carpetas
/share/CACHEDEV1_DATA/.qpkg/plexdrive y
/share/CACHEDEV1_DATA/.qpkg/plexdrive/drive

(16-09-2018, 07:52 AM)enrey escribió: Lo que hago aqui es escribir en putty  /share/CACHEDEV1_DATA/.qpkg/plexdrive/plexdrive.sh y escribo al final el codigo, ¿lo estoy haciendo bien o esta mal?
Acuérdate que hay que dar atributos de ejecución ese archivo de extensión .sh
Si no lo haces no se ejecutará por mucho que lo hagas por script o línea de comandos en putty.
Con un “chmod 755 /share/CACHEDEV1_DATA/.qpkg/plexdrive/plexdrive.sh” debería funcionar.

(16-09-2018, 07:52 AM)enrey escribió:
En el siguiente paso
Ahora el siguiente paso añadirlo al Appcenter, para eso vamos a la siguiente ruta  "/etc/config/qpkg.conf" y añadimos al final del archivo lo siguiente:


Código:
[plexdrive]
Name = plexdrive
Class = null
Status = complete
Version = 0.1
Enable = TRUE
Date = 2017-10-01
Shell = /share/CACHEDEV1_DATA/.qpkg/plexdrive/plexdrive.sh
Install_Path = /share/CACHEDEV1_DATA/.qpkg/plexdrive
QPKG_File = plexdrive.qpkg
Author = abufa

escribo en putty    /etc/config/qpkg.conf  (previamente tuve que dar permisos), y pego al final el codigo, reinicio el qnap, pero no veo ninguna app plexdrive, ni ninguna unidad montada.

Por otra parte he confirmado que no esta enlazado plexcloud, tengo una película en google drive, y haciendo un ls a plexcloud debería salir la película y no sale nada, esto es lo que pongo en putty
ls /share/CACHEDEV1_DATA/homes/admin/Plexcloud/

S@lu2
[quote='enrey' pid='11095' dateline='1537080751']

Prueba a ejecutar “/share/CACHEDEV1_DATA/.qpkg/plexdrive/plexdrive.sh” y comprueba que funciona y accedes a lo que monte o haga el script.



Un saludo
Agur eta ondo ibili
Un saludo

Agur eta ondo ibili

Mon (TS-469Pro y TVS-673)
 Responder
#40
Vale no he creado el scrip plexdrive.sh
¿como se crea?
S@lu2

ya lo he creado y no errores

No lo guardaba con :wq! de ahi que no apareciera
 Responder


Usuarios navegando en este tema: 1 invitado(s)


Powered By MyBB 1.8.6, © 2002-2018 MyBB Group
Hora: 23-10-2018, 01:59 AM