Sobre permisos que no parecen aplicarse
#1
Hola, después de configurar el Nas mas o menos a mi gusto, me meto con el tema de permisos, puesto que casi todo lo estoy haciendo con el usuario admin y no es plan, ya que también estaba accediendo en remoto para ir probando cosas.
Tengo una carpeta raiz llamada Fotos, donde he limitado sus permisos para todos los usuarios como solo lectura excepto el administrador. Además he marcado una opción que pone que solo el propietario, que es el admin, pueda borrar contenido. Marco la opción de aplicar a archivos y carpetas, parece que lo hace puesto que se pega un rato. En usuarios, los dejo todos como solo lectura excepto el admin.
El caso es que si accedo por Qphoto, con un usuario que no es el admin, puedo borrar fotos y entiendo que no debería. Me avisa que sino tengo permisos igual no se puede realizar la acción, luego me dice que la manda a la papelera, pero la termina borrando.
¿Que se me escapa?

Gracias.

Ts251+.
 Responder
#2
Hola

No sé si entiendo a qué te refieres por carpeta raíz. ¿Cual es su ruta absoluta? ¿/Fotos? ¿Está al mismo nivel que /share?

En cuanto a los permisos. Un programa accede con permisos diferentes que los permisos de usuarios creados en QTS.

Digamos que accede como “admin” y luego por programación y permisos internos te deja o no realizar acciones. Por ejemplo podría tener su propia gestión de usuarios independiente de los usuarios de QTS. Imagina una web pública en la que puedes tener multitud de usuarios, pero no tienen porque ser los de la nas.


Un saludo
Agur eta ondo ibili
Un saludo

Agur eta ondo ibili

Mon (TS-469Pro y TVS-673)
 Responder
#3
A veces se me olvida que esto no es un pc. Tienes razón, la carpeta fotos está en share. Si entro a la configuración de esa carpeta compartida, limito el usuario en cuestión a solo lectura. Es decir me aparecen los usuarios creados en el sistema y a uno de ellos le permito leer. Por otro lado, cuando creo los usuarios en gestión de usuarios en configuración general, a este solo le permito lectura para todo.
Más o menos entiendo lo que dices, pero no se que más hacer.
Con Qnap accedo con ese usuario, así que no se como limitar ese acceso a solo lectura.
 Responder
#4
He estado revisando los permisos y no entiendo que pasa. Supongo que me quieres decir que Qphoto accede a la carpeta compartida fotos con unos permisos diferentes a los de los usuarios, pero el caso es como regular entonces lo que Qphoto puede o no hacer, porque yo no veo como. Yo pensaba que si un usario con permisos limitados es el que se loggea en Qphoto, sus propios permisos son los que harán que ese programa actúe de una forma y otra, pero parece que no.
 Responder
#5
Hola
En general para estos programas la gestión de permisos y usuarios se hace desde propio programa.

Lo que tú haces es más a bajo nivel y corres el peligro de que el programa en cuestión no funcione o lo haga erráticamente por falta de accesos adecuados.


Un saludo
Agur eta ondo ibili
Un saludo

Agur eta ondo ibili

Mon (TS-469Pro y TVS-673)
 Responder
#6
Pues desde el programa no veo como. Pero vamos, he eliminado usuarios y creado nuevos y ahora parece que funciona como debe.
Gracias!
 Responder


Usuarios navegando en este tema: 1 invitado(s)


Powered By MyBB 1.8.6, © 2002-2018 MyBB Group
Hora: 25-02-2018, 08:45 AM