Plexdrive
#11
Hola
Ok entendido esto último, pero a ver si me aclaro un poco que me he perdido (estoy espeso los domingos )

¿Como estás haciendo la ejecución del script? ¿Por un qpkg ficticio en el app center o por líneas agregadas en tu autorun.sh?

Haz un “cat /ruta/autorun.sh” para ver el contenido del autorun y escríbelo aquí.


Un saludo
Agur eta ondo ibili
Un saludo

Agur eta ondo ibili

Mon (TS-469Pro y TVS-673)
 Responder
#12
(20-05-2018, 07:19 PM)Ganekogorta escribió: Hola
Ok entendido esto último, pero a ver si me aclaro un poco que me he perdido (estoy espeso los domingos )

¿Como estás haciendo la ejecución del script? ¿Por un qpkg ficticio en el app center o por líneas agregadas en tu autorun.sh?
He probado el qpkg ficticio como está en el OP y no funciona. 

Haz un “cat /ruta/autorun.sh” para ver el contenido del autorun y escríbelo aquí.
Y el autorun tampoco funciona.
Ahora está así
Código:
[~] # vi /tmp/config/autorun.sh
#!/bin/bash
sh /share/CACHEDEV1_DATA/.qpkg/plexdrive/plexdrive.sh
También he probado así y nada.

Código:
#!/bin/bash

/share/CACHEDEV1_DATA/.qpkg/plexdrive/drive mount -c /share/CACHEDEV1_DATA/plexdrive/.plexdrive -o allow_other /share/CACHEDEV1_DATA/homes/admin/Plexcloud -v 3 --cache-file=/share/CACHEDEV1_DATA/plexdrive/cache.bolt

Muchas gracias
 Responder
#13
Hola buenas para empezar muchas gracias por este tutorial he aprendido mucho pero tengo el siguiente problema:

tengo un qnap ts-453a tengo el script creado y sale en la app center como iniciado pero no monta la unidad, hay alguna otra forma de montar la unidad aunque sea manual por el qnap y cuando cierre sesión se mantenga?
 Responder
#14
Hola

Si tienes acceso a consola, yo probaría copiar, pegar de una en una las tres líneas del script para ver si hay algún tipo de aviso.

Y digo copiar pegar y no escribirlo por si hay algún error que se nos pase.
Yo no puedo probarlas porque no tengo esa función, pero estaría bien que alguien del foro que lo tenga hiciese la misma ejecución de las tres líneas.

Una vez funcionen da igual lanzar un autorun, una orden qpkg o una tarea cron para ejecutarlo. El caso es que funcione.


Un saludo
Agur eta ondo ibili

(23-05-2018, 06:41 PM)jose86 escribió: Hola buenas para empezar muchas gracias por este tutorial he aprendido mucho pero tengo el siguiente problema:

tengo un qnap ts-453a tengo el script creado y sale en la app center como iniciado pero no monta la unidad, hay alguna otra forma de montar la unidad aunque sea manual por el qnap y cuando cierre sesión se mantenga?

Caminando te refieres al script, ¿te refieres al qpkg? Lo digo porque son cosas distintas. El qpkg “ficticio” lo que hace es lanzar un script al inicio del arranque de la máquina.
Esto es importante aclararlo por el desactivar ese qpkg en la pantalla del app center no quiere decir que haga la operación inversa cuando lo desactives.

Esto último se puede hacer sin problemas. Es decir al activar la app se monta una carpeta y al desactivar se desmonta la carpeta. Si no lo hiciésemos así, cada vez que activamos la app, se intenta montar algo que ya está montado y dará un error que no somos capaces de ver porque no estamos haciéndolo desde la consola para verlo.

Si alguno está interesado pongo por aquí un código de ejemplo. Yo por ejemplo lo tengo para que me agregue tareas periódicas en el
crontab y cuando lo desactivo, esas tareas son eliminadas y desactivadas del crontab.


Un saludo
Agur eta ondo ibili
Un saludo

Agur eta ondo ibili

Mon (TS-469Pro y TVS-673)
 Responder
#15
(23-05-2018, 06:55 PM)Ganekogorta escribió: Hola

Si tienes acceso a consola, yo probaría copiar, pegar de una en una las tres líneas del script para ver si hay algún tipo de aviso.

Y digo copiar pegar y no escribirlo por si hay algún error que se nos pase.
Yo no puedo probarlas porque no tengo esa función, pero estaría bien que alguien del foro que lo tenga hiciese la misma ejecución de las tres líneas.

Una vez funcionen da igual lanzar un autorun, una orden qpkg o una tarea cron para ejecutarlo. El caso es que funcione.


Un saludo
Agur eta ondo ibili

(23-05-2018, 06:41 PM)jose86 escribió: Hola buenas para empezar muchas gracias por este tutorial he aprendido mucho pero tengo el siguiente problema:

tengo un qnap ts-453a tengo el script creado y sale en la app center como iniciado pero no monta la unidad, hay alguna otra forma de montar la unidad aunque sea manual por el qnap y cuando cierre sesión se mantenga?

Caminando te refieres al script, ¿te refieres al qpkg? Lo digo porque son cosas distintas. El qpkg “ficticio” lo que hace es lanzar un script al inicio del arranque de la máquina.
Esto es importante aclararlo por el desactivar ese qpkg en la pantalla del app center no quiere decir que haga la operación inversa cuando lo desactives.

Esto último se puede hacer sin problemas. Es decir al activar la app se monta una carpeta y al desactivar se desmonta la carpeta. Si no lo hiciésemos así, cada vez que activamos la app, se intenta montar algo que ya está montado y dará un error que no somos capaces de ver porque no estamos haciéndolo desde la consola para verlo.

Si alguno está interesado pongo por aquí un código de ejemplo. Yo por ejemplo lo tengo para que me agregue tareas periódicas en el
crontab y cuando lo desactivo, esas tareas son eliminadas y desactivadas del crontab.


Un saludo
Agur eta ondo ibili

Hola
Después de darle muchas vueltas, mi versión de plexdrive arm no tenía autoarranque por lo visto. Al final lo he solucionado con una tarea en crontab y funciona bien.
 Responder


Usuarios navegando en este tema: 2 invitado(s)


Powered By MyBB 1.8.6, © 2002-2018 MyBB Group
Hora: 26-05-2018, 05:26 AM