Entrada al foro con y sin htpps
#1
Hola!!,

 Me he dado cuenta que al entrar al foro tanto directamente o como por algún enlace a http://www.qnapclub.es  aparece en modo no seguro, en cambio tecleando la dirección completa con el htpps:// entra en modo seguro.

 Editando el .htaccess del servidor del Foro o en Apache se puede solucionar fácilmente el problema añadiendo una sentencia para que redirija todos los accesos http a https.

 Algo similar podría ser:  
Código:
RewriteRule ^(.*)$ https://qnapclub.es/$1 [R,L]



  Saludos
  Jorge
Regla de Calculo > TI-51-III > ZX80 > ZX Spectrum > PC XT > PC AT > PC 386 > PC 486 > Pentium varios > DNS323 > TS-219P II > TS-670 Pro > TVS-882 > ¿?¿?

 Responder
#2
Hola
Esto DonPeter lo soluciona en un pis pas

Y ya que hablas de redirecciones, estoy haciendo pruebas de usar un proxy inverso en la Qnap. ¿Para que ? Imagina que sólo tienes abierto en puerto 443 al exterior.

Pero tienes varias web en tu nas que quieres tener accesibles. Por ejemplo tenemos:
Https://ip_nas:1443/pagina1
Https://ip_nas:1443/pagina2
Https://ip_nas:4080/pagina3
Https://ip_nas Esta es la de QTS

La idea es que desde el exterior sólo tecleas:
https://pagina1.dominio.com
https://pagina2.dominio.com
https://pagina3.dominio.com

Asi llegas a las 3 anteriores y a la de QTS no, por ejemplo.

En cuanto tenga todo probado y solucionado lo pongo por aquí.
Un saludo

Agur eta ondo ibili

Mon (TS-469Pro y TVS-673)
 Responder
#3
Hola, yo para eso uso un container con haproxy, con que lo haces tú?
 Responder
#4
Hola

De momento estoy haciendo pruebas modificando directamente archivos de configuración de apache. Pero son pruebas de fin de semana (entre semana estoy ocupado).
Yo pensaba que haproxy era para balancear carga de una misma web hacia varios servidores. Tendré que echar una ojeada.

Intento evitar instalar añadidos en la Qnap para ganar funcionalidades. Otra cosa es que lo consiga


Un saludo
Agur eta ondo ibili
Un saludo

Agur eta ondo ibili

Mon (TS-469Pro y TVS-673)
 Responder
#5
(11-05-2018, 01:36 AM)jfz62_1 escribió: Hola!!,

 Me he dado cuenta que al entrar al foro tanto directamente o como por algún enlace a http://www.qnapclub.es  aparece en modo no seguro, en cambio tecleando la dirección completa con el htpps:// entra en modo seguro.

 Editando el .htaccess del servidor del Foro o en Apache se puede solucionar fácilmente el problema añadiendo una sentencia para que redirija todos los accesos http a https.

 Algo similar podría ser:  
Código:
RewriteRule ^(.*)$ https://qnapclub.es/$1 [R,L]



  Saludos
  Jorge

Muchas gracias por el apunte jfz62_1. Ya está corregido.

Saludos!
 Responder


Usuarios navegando en este tema: 1 invitado(s)


Powered By MyBB 1.8.6, © 2002-2018 MyBB Group
Hora: 22-05-2018, 06:43 PM