Review adaptador USB a 5Gbe QNAP
#1
Buenas,

Os dejo un vídeo de rendimiento sobre el adaptador QNA-UC5G1T de QNAP


Saludos,
Responder
#2
Hola

Yo tengo ya uno de ellos, estoy haciendo pruebas con un switch con puertos 10GbE.

Aquí tenéis unas fotos.
   
   

El contenido de la misma es el adaptador propiamente dicho con un cable usb-c de unos 20 cm de largo.
   
   
   
   
El adaptador es metálico y de superficie ondulada en la parte superior. Con ello se consigue una mejor disipación del calor. Y es que toda la electrónica de 10GbE y 5GbE tiende a calentarse.

Por casualidad, una de las tapas laterales se desplazó y pude desmontarlo.

La otra tapa NO puede quitarse ya que hay un tornillo bajo la etiqueta de la MAC y el S/N

   

Podemos comprobar que casi todo es material disipador o material termoconductor hacia la carcasa.
   


Las instrucciones son muy escuetas y poco mas nos dicen que la forma de conectarlo y el estado de los leds.
Uno para ver la actividad y otro para ver la velocidad (verde para 5GbE y ámbar para las inferiores).
   

Estoy haciendo pruebas aún en diversos sistemas y máquinas. Espero hacer un hilo mas adelante mostrando gráficas de transferencia y tiempos ahorrados.

Pero ya os puedo decir que en un PC con Linux Mint (Tesa) no he tenido que hacer nada y el sistema lo ha reconocido perfectamente.
En Windows 10 se instala el driver que bajamos de la web de Qnap (es un ejecutable que se instala ) y a funcionar. 
Para usar con ultraportátiles está muy bien, ya que no suelen traer interfaz ethernet por ser muy fino y ademas suelen tener discos ssd. Así las transferencias pesadas se hacen bastante mas rápidas Smile

Y por supuesto, si lo conectamos a nuestras nas de Qnap, aparece un nuevo adaptador disponible.

Ojo que pide QTS 4.3.6 o superior, por ejemplo no sirve para la familia TS-x69.
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be)
Responder
#3
Bueno por he conseguido hacer alguna prueba de velocidad entre una tarjeta de red 10GbE y el adaptador QNA de 5GbE.

Las pruebas las he hecho con el siguiente material:
  • un portátil con Windows 10 Pro 64 bit, una cpu i7 y un disco ssd tipo m2.2242
  • una QNAP TVS-673e con tarjeta de doble propósito QM2-2P10G1T de 10GbE y discos m2. Los datos de prueba están en un raid 5 de discos mecánicos.
  • switch netgear G110EMX
  • cables de cat7 y cat 6
En todos los casos he configurado la MTU de las tarjetas a 9000, frente a los 1500 habituales. Y se ha transferido 7 archivos iso con un total de 13,1 GB.
Las pruebas se han hecho usando protocolo SMB, es decir no he usado navegadores de Internet.

Decir que ambos adaptadores usan el mismo chip de Aquantia

1-Desde la Nas hacia el PC  por conexión directa por cable.
Ambos adaptadores se configuran a la velocidad 5GbE según indican sus leds.
   

Vemos que la velocidad ha tenido picos de 350 MB/s, pero oscila bastante y rendimiento no es muy bueno frente a lo que esperábamos.

2-Desde la Nas hacia el PC  por conexión usando el switch.
La tarjeta de la nas conectada a 10GbE y la QNA a 5GbE
   

Vemos la la velocidad se mantiene en el entorno de los 338MB/s, sin grandes oscilaciones.
Supongo que la mejora se debe al switch y a que la tarjeta de la NAS estaba trabajando a 10GbE.

3-Desde el PC hacia la Nas por conexión directa por cable.
Ambos adaptadores se configuran a la velocidad 5GbE.
   

En la gráfica vemos bastantes oscilaciones en la transferencia con valores de 170MB/s a 70 MB/s, pero con una media bastante baja

4-Desde el PC hacia la Nas por conexión usando el switch.
La tarjeta de la nas conectada a 10GbE y la QNA a 5GbE
   

En la gráfica vemos bastantes oscilaciones en la transferencia con valores de 170MB/s a 70 MB/s, pero mejor que el caso anterior.

Así a simple vista, podemos ver que el trabajar con la tarjeta de la NAS a 10GbE con el uso del switch mejora bastante el resultado.

Si puedo ampliaré este comentario con las transferencias desde algún equipo con Linux.
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be)
Responder
#4
Gracias Ganeko por el test.!
Responder
#5
Hola

Hoy estuve haciendo unas pruebas de velocidad con un equipo i5 -2500K con Linux Mint 19.2 Tina y con disco duro mecánico.
Se han hecho las pruebas variando las conexiones de PC:
  • con el adaptador USB 3.0 QNA 5GbE. Con chip Aquantia
  • con una tarjeta ASUS de 10GbE modelo XG-C100C. Con chip Aquantia
  • con un adaptador USB 3.0 de 1GB de marca ACME Wink .Con chip Realtek
La Nas es una TVS673 con una tarjeta de 10GbE y discos duros mecánicos en raid 5
El switch es un GS110EMX.


Se han hecho pruebas de transferencia de 7 archivos ISO con un total de 14,1 GB. He creado un par de scripts que presenta en pantalla la hora inicial y la hora final de la copia de archivos.

1-Copiando de la NAS con el adaptador a 10GbE hacia PC con el adaptador QNA de 5GbE
   
Ha tardado 4 minutos y 19 segundos. Es decir 259 segundos para 14,1GB, un promedio de 55 MB/s

Si hacemos pruebas con iperf3 durante un minuto tenemos el siguiente resultado
   
Nos muestra 91.4 MB/s. Es mas alto porque transmite mucha menos información y los picos iniciales nos incrementan el resultado real.

2-Copiando del PC con el adaptador QNA de 5GbE hacia la NAS con el adaptador a 10GbE
   
Ha tardado 4 minutos y 13 segundos. Es decir 253 segundos para 14,1GB, un promedio de 57 MB/s

Si hacemos pruebas con iperf3 durante un minuto tenemos el siguiente resultado
   
Nos muestra 91.4 MB/s 


3- Copiando de la NAS con el adaptador a 10GbE hacia PC con una tarjeta de 10GbE
   
Ha tardado 4 minutos y 11 segundos. Es decir 251 segundos para 14,1 GB que hacen un promedio de 57.5 MB/s

Si hacemos pruebas con iperf3 durante un minuto tenemos el siguiente resultado
   
Nos muestra 745 MB/s

4-Copiando del PC con tarjeta de 10GbE hacia la NAS con el adaptador a 10GbE
   
Ha tardado 4 minutos y 9 segundos. Es decir 249 segundos para 14,1 GB que hacen un promedio de 57,98 MB/s


5- Copiando de la NAS con el adaptador a 10GbE hacia PC con adaptador USB de 1GbE
   
Ha tardado 12 minutos y 34 segundos. Es decir 754 segundos para 14,1 GB que hacen un promedio de 19.15 MB/s

Si hacemos pruebas con iperf3 durante un minuto tenemos el siguiente resultado
   
Nos muestra 29,8 MB/s

6-Copiando del PC con un adaptador USB de 1GbE hacia la NAS con el adaptador a 10GbE
   
Ha tardado 13 minutos y 9 segundos. Es decir 789 segundos para 14,1 GB que hacen un promedio de 18.30 MB/s

Si hacemos pruebas con iperf3 durante un minuto tenemos el siguiente resultado
   
Nos muestra 29.8 MB/s

Como resumen podemos decir que el tener todo con tarjetas de 10GbE no exprimen nuestra comunicaciones si nuestros discos son mecánicos. 
Ya que haciéndolas a 5GbE obtenemos los mismos resultados en transferencias voluminosas.

Si encuentro algún programa en Linux que nos muestre gráficamente las velocidades durante toda la copia, pondré algunas capturas complementarias.
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be)
Responder




Usuarios navegando en este tema: 1 invitado(s)