Velocidad lectura-escritura QNAPTS251
#1
Buenas,
Tengo un QNAP TS251. Lo uso para guardar mis datos y como servidor multimedia. Los ficheros multimedia que tengo son bastante pesados, 80Gbs con bitrates de 50Mgs. Son ficheros con resolución 4K y sonido dolby atmos 7.1. Tengo conectado en red a un reproductor, todo con conexión gigabit y con cable cat6. Para que se vea mejor, dejo una imagen de como tengo montado todo en casa. 
La cuestión es que, de vez en cuando alguna película va a tirones. He revisado la red y el reproductor, parece que funcionan OK. Por lo que sé la velocidad de lectura-escritura de este NAS es de 220Mb/s. El NAS lo no lo tengo en raid, sino en simple, para poder sumar capacidad de almacenaje. El disco 1 es de 10Tb y el disco 2 es de 2Tb. Al disco 1 descargo todo el contenido multimedia. Al disco 2 mis datos. El reproductor lee del disco 1 pero a su vez el disco 1 también esta compartido los ficheros en el tracker. Y todo ello tiene que pasar entre los 2 swicht que tengo. 
¿Podría ser que el HDD 1 o en NAS no tengan la suficiente velocidad para esta función?  cambiando el disco 2 a uno de 10Tb y poniendo el nas en raid1, mejoraría la velocidad? o necesito un NAS mas rápido?

Saludos


Archivos adjuntos Imagen(es)
   
  Responder
#2
Hola
El cuello de botella en la transferencia lo tienes en el ancho de banda de salida de tu nas.

Capacidad de transferencia de tus discos es interna, por ejemplo si copias de disco a disco, notarías las velocidades que dices.

Pero la que te limita es la tarjeta gigabit hacia el exterior.

Realmente el problema viene porque los vídeos cada vez ocupan más, tienen mayores resoluciones y tasas de refresco.

Aquí hay usuarios que han ido ajustando esos vídeos a resoluciones y codecs que les van bien y encajan en su instalación.
Por ejemplo no tiene sentido querer visualizar vídeos 4K en un equipo con una pantalla de 15” , con tenerlos a 720p sería suficiente.

No recuerdo si ese modelo tiene dos puertos 1GbE, pero podrías agruparlos con 802.3ad y si el equipo que va a visionar tiene la opción de agrupar tarjetas notarías la mejoría.
Otra opción es mejorar la red con velocidades y tarjetas superiores de 2.5 , 5 o 10 GbE.
En el caso de la nas y el pc con adaptadores de usb a 5GbE por ejemplo los QNA-UC5G1T
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder
#3
La verdad es que las películas cada vez tienen mas peso e información; cuesta mucho moverlas. Yo la veo en una TV de 65" y estoy pensando en dar el paso a proyector de 120" por lo que me interesa que la calidad del contenido a reproducir sea buena.

El reproductor que tengo es un reproductor a secas, traga todo lo que le pongas y saca muy buena calidad de imagen, pero poco mas. No puedes actualizar firmware o configurar tarjeta de red. El TS251 si que tiene 2 puertos de 1GbE. Pero viendo que el reproductor no lo puedo configurar, agrupar los puertos del NAS, supongo que de poco valdría no?

Esos adaptadores USB para NAS, mejorarían la velocidad de salida de datos del NAS, pero el cuello de botella seria los switch gigabit que tengo, no? habria que hacer algun cambio en los switch gigabit?
Otra cosa, si me conecto con esos adaptadores USB, la dirección IP del NAS cambiaria? no mantendría la que tengo conectado a través de ethernet, no?

Gracias por la respuesta y saludos
  Responder
#4
Hola
Si, tal como dices el siguiente cuello sería el switch y luego el de tu reproductor.

Para que se note la mejora, todos los elementos deberían tener una mejor comunicación, ya que si no es así, la velocidad máxima de una comunicación es marcada por la del elemento más lento.

En tu modelo la máxima velocidad de comunicación por red que puedes alcanzar actualmente es con dos QNA-UC5G1T (o similares). Uno lo conectas al usb3 frontal y otro al usb3 trasero. Los agrupas y podrías conseguir una conexión equivalente de 10GbE.

Pero claro, necesitamos un switch con puertos de al menos 5GbE y algo similar en tu “inmodificable” reproductor, con lo que está solución no es factible.

Vamos que no te merece económicamente y tampoco técnicamente por la limitación del reproductor.

Por tanto, habrá que centrarse en optimizar de alguna forma los vídeos. Ver cuál es el codec y resolución que mejor te encaja con tus 65” o 120” (que envidia me das )
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder
#5
Hola 

Algo que no se suele mirar y que en su caso me trajo de cabeza es comprobar que la TV 4k en la que se reproducen los ficheros tenga una tarjeta de red Gigabit.
No es el primer caso en el que es una trajeta 10/100 y es donde aparece la limitación. En algunos casos hay TV que van mejor con la wifi 5 ghz inetgrada que por ethernet.

supongo que no es el caso, pero sucede. 

También hay TV 4k con Android TV que llevan procesadores de baja gama Mediatek o similares con poca memoria ram y poca capacidad y son los responsables de los saltos.

Hablo siempre de mi experiencia en PLEX. Mi camino para descubrir el cuello de botella siempre ha tenido como sospechoso al NAS, pero en la mayoría de casos el problema estaba en el reproductor.

EDITO: veo que tienes un clon del Oppo. en ese caso si que lleva tarjeta 1G y ese equipo deberia procesar de forma correcta el fichero para reproducirlo en la TV
  Responder
#6
Hola
Tal como dice Miffa, es difícil descubrir al culpable de los tirones de video y tendemos a sospechar de la nas.
En mi caso particular fue con unos pocos videos y era el por el codec usado. Pero me costó bastante encontrar el motivo ya que hay muchos ajustes en los reproductores.

De momento lo que mejor me va es usar plex co o addon de kodi y visionar por hdmi(pero notodas tienen hdmi).


Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TS-453Be y TVS-673)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder
#7
Hola,

Gracias a los 2.

Mi Tv lleva un procesador de imagen X1 extreme y tiene ethernet gigabit. Es android tv y para contenido ligero va bien pero con peliculas pesadas va a tirones. Tengo la sospecha que es porque es android. El clon del oppo, es un buen reproductor y lleva puerto gigabit. Mucha gente lo tiene y no tienen problemas con él. No deberia ser el problema.

Como bien dice Ganekogorta pasar a 5Gb me saldria un ojo de la cara. Seria mucho cambio.

He hecho lo siguiente: me he fijado que al NAS le costaba mucho abrir la pagina de ru-torrent. Cuando añadia un torrent nuevo le costaba mucho empezar a bajar. Hacia cosas raras. En otro foro he leido a un compañero con problemas parecidos. No cerraba bien el cliente torrent y de ahi le venian los problemas.
Por otra parte he visto que el NAS casi siempre tengo el procesador al 50-60% y la memoria al 50%. He eliminado procesos que uso poco. He cerrado correctamente ru-torrent y reiniciado el NAS. Ahora el procesador esta al 20% y la memoria al 40%
Tras esto he hecho un par de pruebas con peliculas pesadas y parecia que iba mejor. A la segunda pelicula, esta muy pesada, casi 100Mgb de bitrate, la movia bien pero de repente se ha parado. He ido al PC e intentado acceder al NAS pero no me podia conectar. Conexion rechazada. He tenido que apagar el NAS. Hay alguna forma de saber si el NAS tiene problemas de conexion a la red? o porque se desconecta asi, sin mas?

Saludos
  Responder
#8
Mi Tv tambien tiene el procesador X1 xtreme , pero el Android TV lo mueve otro procesador. Puede ser que solo procese la señal que ya le llega a la pantalla para mejorarla y no sea el encargado de resproducir en primera instancia.

Para ver si acertamos en el cuello de botella.

Tengo fibra 600 Mbits y un Switch dell de 1Gb con 24 puertos en modo NO gestionado. todos los cables son cat 6 

Yo tengo el mismo modelo de NAS que tu en 4 bahías con 8 megas de ram y me lo reproduce TODO sin problemas excepto los ficheros que tu comentas, 4k con tasas de bits altísimas.
Pega pequeños tirones. Esto siempre con el procesador con menos del 10 - 20 % de uso, puesto que no uso nada más que la app de unifi para la wifi (usa memoria pero poca CPU)

Para descartar cosas monte Plex en una maquina con windows server en un Xeon con 16gb de Ram. La máquina no corre nada más que Plex y los servicios propios del Windows
Tengo los mismos problemas de tirones, muy pequeños pero muy molestos.

Cuando pruebo la TV, conectada a la red ethernet y "supuestamente" con una tarjeta de 1Gb nunca consigo más de 100 Mbs con Fast de Netflix lo que me hace sospechar que mi problema es la TV.

De todas maneras

¿con que reproduces los videos? Plex, VLC, otra App.?? Creo que es algo importante
¿te pasa lo mismo con el archivo multimedia reproduciendo a  través de USB 3.0? 

Supongo que lo que comentas es te pasa con el nas puede deberse a que se llena el buffer y algún proceso genera un error y el interfaz de red se bloquea. Es como cuando el Plex intenta decodificar un fichero con un códec, subtitulo o algo que no soporta o tiene algún error y se cuelga obligando a reiniciar.

Por cierto - ligero off topic - me han dicho que el clon de oppo es una maravilla. ¿Donde se pueden adquirir? si no es indiscreción
  Responder
#9
Tengo fibra 100Mg y los 2 swicht que tengo son de 8 puertos, creo que tambien no gestionados. No he configurado nada, tenia entendido que eran plug and play. Son estos 2:

https://www.tp-link.com/es/business-netw.../tl-sg108/

https://www.tp-link.com/es/home-networki...g1008d/v8/

El NAS lo tengo con 4gb de ram. Solo lo tengo para las descargas y como servidor DLNA, TWONKY. Para las series reproduzco con la TV con la app Kodi. Para las peliculas simpre con el clon oppo (da igual que pelicula sea 4K, 1080P, 720p, remux,...), accedo al NAS por NFS o Samba.

Nunca reproduzco o hago trasncodificacion con el NAS.

Probaré a reproducir por USB3.0. Tiene suficiente velocidad como para ese tipo de peliculas 4K?

Ahora mismo he puesto otra vez la pelicula de 100Mgs de bitrate y al rpincipio iba bien pero al rato va a tirones. Os paso una captura de los recursos. No le veo nada raro...


Respecto al off-topic; los consegui a traves de avpasion, compra conjunta. Pero este reproductor ya no se fabrica ahora hay otros modelos con lector disco, mas potentes, y mas caros...


Archivos adjuntos Imagen(es)
   
  Responder
#10
es normal que a 4k te de tirones,ese nas lo optimo seria a 1080p.
yo tengo plex y todas las series y pelis,las tengo o a 1080p o a 750p en caso de las series.
tengo un ts-251+ y es capaz con los archivos que tengo de servir a 5 usuarios sin problemas
Ausente
  Responder




Usuarios navegando en este tema: 1 invitado(s)