• 1 voto(s) - 5 Media
  • 1
  • 2
  • 3
  • 4
  • 5
VPN WireGuard en docker v1.12
#11
(19-06-2021, 09:19 PM)Ganekogorta escribió: Hola

He hecho la prueba de poner ese container en la misma red que otros y si me contestan a los pings desde el móvil.

Es decir veo a la red donde está la nas y también a los contenedores del rango de red de wireguard.
Hola, Buenos dias, como cambias la red del container? Lo que probé el otro día es a cambiar las ip de los archivos wg0.conf y cliente.conf del tutorial con las que me aparecen en conmutador virtual donde me aparecen las redes de los contenedores, pero no funciona, hay he visto que todos los contenedores que no tengo acceso me aparecen en la red 10.0.3.1 y el wireguard está en la 172.29.4.1, no sé si me estoy liando yo solo, muchas gracias, un saludo
  Responder
#12
Hola

No se el nombre que tienes de red para los otros dockers.

Pero sería agregar el parámetro “- -network=tu_red” en la definición del docker.

O agregarlo en la definición de yaml. Echa una ojeada a https://medium.com/@caysever/docker-comp...6e424fad82

Pero si no quieres liarte mucho, yo lo hice desde portainer. Que me parece mucho más cómodo, me estoy haciendo un vago
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder
#13
Gracias por toda la información, tendre que mirarlo tranquilamente, a ver si me aclara algo, en portainer sería dentro del contenedor a modificar, editar/duplicar y en el apartado network elegir la interfaz donde están los demás contenedores y guardar en el mismo contenedor o que te haga uno nuevo, verdad? Estoy empezando con portainer y ando más perdido….
  Responder
#14
(20-06-2021, 11:36 AM)Jedha escribió: Gracias por toda la información, tendre que mirarlo tranquilamente, a ver si me aclara algo, en portainer sería dentro del contenedor a modificar, editar/duplicar y en el apartado network elegir la interfaz donde están los demás contenedores y guardar en el mismo contenedor o que te haga uno nuevo, verdad? Estoy empezando con portainer y ando más perdido….
Instala Portatiner que te va a facilitar mucho el trabajo, pruebas y despliegues.

Si, es tal como dices lo de la definición de la red
   

Incluso podrías definir su ip.

   
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder
#15
   

Buenas, pues ya está funcionando wireguard con todos los contenedores, veo que no te elimina la otra red sino que hace como una pasarela entre las dos para que se vean entre si, he probado a eliminar la red 172.29.4 y no me arrancaba wireguard, menos mal que he guardado unas capturas con la configuración de esa red, la he vuelto a crear, la enlazado de nuevo con el contenedor de wireguard, y a vuelto a funcionar de nuevo, la verdad que portainer te quita muchos quebraderos de cabeza, muchas gracias Ganekogorta por toda tu ayuda e información facilitada, más adelante intentaré hacer otro docker solo con la red que me interesa, un saludo
  Responder
#16
Funciona bien, gracias
  Responder
#17
Gracias por el tutorial, estoy en ello. Tengo un problema y es que wireguard al importar el archivo en Android da error de atributo desconocido en el interface. Estoy mirando y en las claves, cuando entra algún signo en el archivo si lo abro se ve que en el momento que aparece uno de esos signos como / ó + la linea cambia de color. Puede ser eso?

Edit: bueno he configurado a mano wireguard en android y no tengo internet en el movil ni puedo acceder al Nas pero wireguard aparece como conectado. A saber que está fallando.

Edit: he conseguido internet, había un lio con las direcciones (no tengo muy claro como saber si estoy saliendo a la internet por el Nas). Pero sigo sin poder acceder a mi Nas. Uso Qfile con la misma configuración que uso cuando primero me conecto por Openvpn.
  Responder
#18
Hola

Confirmarte que el cliente de wireguard aunque marca conectado no da error si no lo está
Yo tras la “conexión” hago siempre un ping a una máquina de la red de la nas.

Para saber si estás saliendo o or la vpn de la nas habrás de comprobar si la ip por la que sales a internet es la misma.

Puedes probar yendo a https://ip.irontec.com/ , https://miip.es/ o una legión de webs similares.
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder
#19
(14-08-2021, 11:50 PM)Ganekogorta escribió: Hola

Confirmarte que el cliente de wireguard aunque marca conectado no da error si no lo está
Yo tras la “conexión” hago siempre un ping a una máquina de la red de la nas.

Para saber si estás saliendo o or la vpn de la nas habrás de comprobar si la ip por la que sales a internet es la misma.

Puedes probar yendo a https://ip.irontec.com/ , https://miip.es/ o una legión de webs similares.
Bueno borro todo el mensaje churrero que había escrito y declaro públicamente que me rindo, llevo dos días con el tema, pensaba que conectaba a las carpetas del Nas a través de Wireguard y ahora resulta que entraba porque a pesar de que Qfile lo había configurado para que accediera solo vía ip local, había vuelto a coger la ddns y entraba por myqanpcloud. En fin, gracias por el tutorial y saludos a todos.
  Responder
#20
Por mi parte todo me ha funcionado bien, tengo wireguard en marcha. Gracias !!!.
  Responder




Usuarios navegando en este tema: 1 invitado(s)