WireGuard VPN en QTS 5.0
#21
aquí estamos para lo que se pueda ayudar Smile

Un saludo y feliz año
  Responder
#22
Una pregunta de novato total.
Cuando voy a emparejar mi móvil me da 3 opciones, a partir de un fichero, con un código QR y de forma manual. La pregunta es ¿cómo se genera ese codigo QR desde el wireguard?
no veo la opción por ningun sitio.
gracias
  Responder
#23
Buenos días,

hasta donde yo se en qnap no hay una herramienta automática que permita hacer esto, pero estaría bien la verdad.

he hecho una búsqueda rápida a ver como se podría solucionar ya que la mayor ventaja que le veo es conseguir que un miembro de la familia que no se entere mucho configure rapidamente la vpn.

Desde la siguiente página web puedes generar el QR:

https://www.wireguardconfig.com/qrcode

Antes necesitas tener claros los datos de configuración y haber configurado el cliente en el servidor, para ello necesitas un juego de claves (privada y pública) para el cliente. No se si existe un generador online, pero puedes generar un juego desde cualquier cliente de wireguard.

Una vez tengas el juego de claves, das de alta al cliente en el servidor (añadir homólogo).

Como último paso tienes que crear el texto de configuración que usarás para crear el qr. Podría ser parecido a esto:

[Interface]
Address = 198.0.0.1/32 (aquí va la ip que hayas configurado en el servidor para este dispositivo)
DNS = poner un dns (8.8.8.8 por ejemplo)
PrivateKey = clave privada del dispositivo

[Peer]
AllowedIPs = 0.0.0.0/0
Endpoint = dirección del servidor
PublicKey = clave publica del servidor 


Espero que sirva, y seguro que en el foro hay gente que sabe mucho más que yo.

Un saludo.
  Responder
#24
muchas gracias, la idea era esa, que los más patosos tuvieran una forma rápida de acceder al VPN. Voy a probar y ya te comento.
  Responder
#25
Hola a todos.

Tengo configurado el acceso remoto al NAS a través del Wireguard, uso el NAS para mi trabajo y así puedo acceder desde un portátil o desde el móvil para consultar los trabajos fuera del despacho. Lo hice siguiendo los pasos de este hilo (muchas gracias al autor) y todo me iba perfecto hasta hoy. Debe haber problemas con Myqnapcloud porque no puedo acceder al NAS y en estado de conexión me pone "Anormal" y no hay forma de conectar.

Mi pregunta es si en [Peer], Endpoint puedo poner la dirección ip pública, la ip local del nas u otro parámetro distinto a la dirección myqnapcloud, Supongo que este problema se arreglará, pero no puedo estar a expensas de que el servicio se caiga.

He probado a poner en Endpoint la ip pública del despacho, la ip local del nas y no consigo conectarme al nas

Ahora lo tengo así:
[Peer]
PublicKey = xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
AllowedIPs = 0.0.0.0/1, 128.0.0.0/1
Endpoint = xxxxxxxxxxxxxx.myqnapcloud.com:51820
PersistentKeepalive = 25

He probado con la ip pública
[Peer]
PublicKey = xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
AllowedIPs = 0.0.0.0/1, 128.0.0.0/1
Endpoint = xxx.xxx.xxx.xxx:51820
PersistentKeepalive = 25

Y con la ip local del NAS:
[Peer]
PublicKey = xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
AllowedIPs = 0.0.0.0/1, 128.0.0.0/1
Endpoint = 192.168.1.149:51820
PersistentKeepalive = 25

No consigo conectar con ningún método, solo con la dirección myqnapcloud.

En Interface lo tengo así

[Interface]
PrivateKey = xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Address = 198.18.7.4/32
DNS = 8.8.8.8

El puerto 51820 abierto en el router.

¿Se me escapa algún parámetro, estoy haciendo algo mal?

Un saludo y gracias.
  Responder
#26
por curiosidad las pruebas las estas haciendo desde el despacho?
  Responder
#27
(30-03-2022, 11:36 AM)Gwaihir escribió: por curiosidad las pruebas las estas haciendo desde el despacho?

No, las estoy haciendo desde fuera del despacho. Estoy en el despacho de un compañero y desde aquí siempre me funcionó hasta hoy, que debe haber un problema con el servicio myqnapcloud. Tampoco me funciona desde el móvil. 

Por aclarar, con las pruebas que estoy haciendo, Wireguard parece que se conecta, pero al intentar acceder al nas no puedo.

El cliente de wireguard crea algún log para ver si da algún error?
  Responder
#28
Me desconcierta el tema de que funcionase hasta hoy...

Podría haber algún fallo en myqnapcloud pero si tienes la ip publica del router de tu despacho debería conectar igualmente.

El puerto 51820 esta abierto en UDP?
  Responder
#29
Hola

Prueba a usar otra dirección ddns. Por ejemplo con DuckDNS, parece que últimamente myqnapcloud no va muy fino.

Y respecto a tcp/udp, depende de lo que hayas tenido antes. Si no estás seguro, abre ambos en el Router , una vez veas que si conectas y accedes, cambia a sólo udp o tcp para ver si es el correcto.


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673e, QBoat Sunny, TS-453Be y QHora-301w)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny, TS-453Be y QHora-301w) Ʀɐɯ0η
  Responder
#30
buenas, he configurado wireguard en el nas i en el iphone, el nas me dice que esta enlazado en la grafica de datos "r" y "t" estan con cifras en movimoento pero si desactivo la wifi y navego solo con 4g no puedo conectarme. Me pasa lo mismo con "plex"
uso el ddns de qnap.
podeis ayudarme?
gracias
usuario mac
qnap tvs463
  Responder




Usuarios navegando en este tema: 1 invitado(s)