Dockers en QNAP
#1
Hola,
Tengo un TS-228A donde tengo varios docker corriendo. Tengo una LXC quiero pasar a docker ya que se termina el soporte a fin de año. El problema es que creo un docker con una máquina debian (Debian docker oficial) y no logro que los servicios se levanten al iniciar el sistema (un apache2 básicamente). Tampoco logro que funcione el cron.
Veo que los servicios están en /etc/init.d y a mano sí arrancan sin problemas.

Tengo otras máquinas donde sí funciona así que no se si ha cambiado algo últimamente que hace que esto no funcione correctamente. LLevo un mes buscando información y no logro nada. Incluso me he creado mi propio docker pero no logro que arranque... Sad

¿Alguna idea?

Muchas gracias.
  Responder
#2
Hola

¿Has comprobado si el docker que quieres es soportado por tu arquitectura?
Lo digo porque aunque sea un ARM, dentro de ellos hay versiones.

Me pegué con el caso del docker de wireguard para ARM y para los Annapurna AL-214 no funcionaba, pero si para los AL-314


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder
#3
Hola,
Gracias por la contestación. La cosa es que el docker arranca sin problemas. Lo que no hace es iniciar los servicios (el apache) que, entrando por consola al sistema, si los inicias a mano funcionan fenomenal.
Saludos.
  Responder
#4
Hola
A ver si me aclaro un poco.
Hablas de docker pero luego hablas de servicios locales de la nas
¿Puedes poner la cadena de creación del docker ?


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder
#5
Hola,
Voy a intentar explicarme mejor.
Creo un docker desde el ContainerStation -> Create -> DockerHub -> Ubuntu official -> Install

Una vez creado el docker, este arranca perfectamente y puedo acceder a él mediante la consola.
La cuestión viene ahora, ya con el docker funcionando y desde la consola, si instalo servicios (en mi caso apache2: "apt-get install apache2") me los instala pero no los arranca al reiniciar el docker.
El problema no se si estará en el propio docker, en la gestión de dockers realizada por Qnap,...

Tengo otro docker creado y arrancado ya hace tiempo que funciona correctamente.

Espero haberme explicado mejor.
Mil gracias por vuestro tiempo.
Saludos y felices fiestas.


Archivos adjuntos Imagen(es)
       
  Responder
#6
Hola
Entendido ahora.

El problema no es del gestor de contenedores, es un problema interno del contenedor que no activa al inicio algo contenido en él.

Yo probaría con algo tipo
sudo update-rc.d apache2 defaults
Pero al ser un docker, no se si tendrá la estructura y contenidos de un ubuntu completo

Tengo que reconocer que no es algo habitual. Es muy posible que haya contenedores de sólo apache2 y de sólo ubuntu. Yo probaría a buscar uno con ambas cosas


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder
#7
Hola,
Ya probé lo de update-rc y tampoco funciona.
Estoy probando distintos contenedores a ver si alguno funciona. También estoy intentando hacerme uno propio con lo que me interesa. De momento no he logrado nada pero sigo intentándolo.
Ya te digo que antes esto no era así. Tengo otros contenedores funcionando perfectamente. Tanto en docker como en LXC...
Gracias y saludos!!!
  Responder
#8
Hola

¿Y usar un script en cron que compruebe que si no está funcionando apache2 lo inicie?


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder
#9
Hola,
También lo pensé pero el cron tampoco funciona... Sad

Saludos
  Responder
#10
Hola
Vaya, eso ya es más raro.
Sin saber el ubuntu docker que tienes ¿no te sale mejor tener un apache2 en docker?


Un saludo

Agur eta ondo ibilli

Mon (TS-469Pro, TVS-673, QBoat Sunny y TS-453Be)
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny y TS-453Be) Ʀɐɯ0η
  Responder




Usuarios navegando en este tema: 1 invitado(s)