Transmission 3 con trackers https
#1
Hola

Llevo varios años usando Transmission como cliente Torrent. Se que hay otros pero me resuelve mis necesidades y está bastante estandarizado en el mercado.
En el PC uso un cliente GUI de entorno mejor que la espartana web de transmission.
El paquete qpkg que uso es la version 3.0.2 bajado de Qnapclub.eu

Hace unos pocos meses comencé a tener problemas con los torrent de un tracker privado.Se ponían en rojo y no se compartían.
El motivo es que ese tracker han cambiado la direccion de http://tracker a https://tracker

Para corregirlo tenemos que hacer un par de cosas:
1- Detensmo la aplicacion desde el app center editamos el archivo Qtransmission3.sh . Para buscarlo lo mejor es abrir una consola y ejecutar el comando "find /share/ -name QTransmission3.sh"
Lo editamos y veremos algo similar a esto

Código:
#!/bin/sh
CONF=/etc/config/qpkg.conf
QPKG_NAME="QTransmission3"
QPKG_ROOT=/sbin/getcfg $QPKG_NAME Install_Path -f ${CONF}
export QNAP_QPKG=$QPKG_NAME
export QPKG_ROOT QPKG_NAME

Le agregamos dos líneas mas para que quede como lo siguiente
Código:
#!/bin/sh
CONF=/etc/config/qpkg.conf
QPKG_NAME="QTransmission3"
TR_CURL_SSL_NO_VERIFY=1
QPKG_ROOT=/sbin/getcfg $QPKG_NAME Install_Path -f ${CONF}
export QNAP_QPKG=$QPKG_NAME
export QPKG_ROOT QPKG_NAME
export TR_CURL_SSL_NO_VERIFY

Guardamos el archivo e iniciamos la aplicación desde el App Center.
Luego desde el entorno web o desde el cliente GUI permitimos el cifrado si es que lo tenemos inhabilitado.
   

Desde ese momento ya podemos hacer descargas desde ese tracker.
Si queremos que las hechas anteriormente estén operativas editaremos sus propiedades y cambiamos su dirección http:// por https://
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny, TS-453Be y QHora-301w) Ʀɐɯ0η
  Responder
#2
Hola Ganekogorta,

Tengo este problema con un cambio de tracker reciente.

He seguido los pasos que indicas pero me sigue sin conectar y lo raro es que un archivo del anterior tracker que funciona con http sigue funcionando bien, cuando entiendo que con estos cambios debería de funcionar sólo con los que usan https

El Qtransmission3.sh lo he editado con WinSCP y si lo abro de nuevo me aparecen las modificaciones.

El Transmission lo he parado e iniciado varias veces y sigue igual.

¿Alguna idea de dónde está mi error?

Un saludo
  Responder
#3
Hola
Es importante que esté detenido transmission antes de hacer de hacer cambios en el archivo json.

Y sólo afecta a los trackers que requieran https.

¿Puede ser tengas torrentes bajados con http y ahora el Tracker los ha cambiado a https? Si es así, has de editar el torrent y modificar la dirección.
Un saludo

Agur eta ondo ibili

Ganekogorta (TS-469Pro, TVS-673e, QBoat Sunny, TS-453Be y QHora-301w) Ʀɐɯ0η
  Responder
#4
Si, lo había detenido tal como indicabas y de hecho, los cambios se han guardado, pero sigue sin funcionarme...

Es un tracker que migra a otro pero tienen los 2 activos simultáneamente. Los el antiguo, con http siguen funcionando, pero el nuevo, que son https no.

A ver si doy con la techa. En este enlace (lo pongo por si a alguien le sirve) hablan de un problema de certificados pero no localizo el QPerl para mi TS-228

https://forum.transmissionbt.com/viewtopic.php?p=78853

Un saludo
  Responder




Usuarios navegando en este tema: 1 invitado(s)